aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2023-05-09 10:49:32 +0200
committerMagneFire <dgriet@gmail.com>2023-05-14 19:38:55 +0200
commitc206053240d39ba1ae3b045566274bde3b40ad3e (patch)
tree373213c31f893740f423fa26ffc8760ac991a7c1 /CMakeLists.txt
parente78b0968ae9ab48a815319b8f6d87ac0e9df95b7 (diff)
Move main library file to CMAKE_INSTALL_LIBDIR and add a launch script
Previously the main program file was installed to /usr/bin, mistakingly giving the impression it could be executed as is. However it isn't a binary but a library that gets executed through invoker. To prevent confusion move it to /usr/lib and add a launch script to /usr/bin instead which launches it through invoker
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a227e4c..8b7965f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,13 @@ include(AsteroidTranslations)
add_subdirectory(src)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/asteroid-helloworld.in
+ ${CMAKE_BINARY_DIR}/asteroid-helloworld
+ @ONLY)
+
+install(PROGRAMS ${CMAKE_BINARY_DIR}/asteroid-helloworld
+ DESTINATION ${CMAKE_INSTALL_BINDIR})
+
generate_desktop(${CMAKE_SOURCE_DIR} asteroid-helloworld)
feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)