aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a227e4c..8b7965f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,13 @@ include(AsteroidTranslations)
add_subdirectory(src)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/asteroid-helloworld.in
+ ${CMAKE_BINARY_DIR}/asteroid-helloworld
+ @ONLY)
+
+install(PROGRAMS ${CMAKE_BINARY_DIR}/asteroid-helloworld
+ DESTINATION ${CMAKE_INSTALL_BINDIR})
+
generate_desktop(${CMAKE_SOURCE_DIR} asteroid-helloworld)
feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)