aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArseniy Movshev <dodoradio@outlook.com>2022-10-22 13:31:50 +0100
committerArseniy Movshev <dodoradio@outlook.com>2023-01-07 14:19:27 +0000
commit95c72f71f9382e3bf2918892edc1e7137391554d (patch)
tree4eb93e137d72c7c8bb5604d8a66b6315ab0f87a9 /CMakeLists.txt
parentb2f45991df2498a050352f3c6dd8c956bde535ee (diff)
Fork from asteroid-stopwatch and initialise repo
copied over the asteroidos boilerplate from asteroid-stopwatch and removed everything else started work on getting a UI to show up
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8f3648a..dc8cba6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,8 +1,8 @@
cmake_minimum_required(VERSION 3.6.0)
-project(asteroid-stopwatch
+project(asteroid-map
VERSION 0.0.1
- DESCRIPTION "Default stopwatch app for AsteroidOS")
+ DESCRIPTION "Map app for AsteroidOS")
find_package(ECM REQUIRED NO_MODULE)
find_package(AsteroidApp REQUIRED)
@@ -11,7 +11,7 @@ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ASTEROID_MODULE_PATH})
include(FeatureSummary)
include(GNUInstallDirs)
-include(ECMQMLModules)
+include(ECMFindQmlModule)
include(AsteroidCMakeSettings)
include(AsteroidTranslations)
@@ -20,6 +20,6 @@ ecm_find_qmlmodule(Nemo.Configuration 1.0)
add_subdirectory(src)
build_translations(i18n)
-generate_desktop(${CMAKE_SOURCE_DIR} asteroid-stopwatch)
+generate_desktop(${CMAKE_SOURCE_DIR} asteroid-map)
feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)