summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-04-23 14:24:16 +0200
committerMagneFire <idanlcontact@gmail.com>2021-05-17 13:01:52 +0200
commitfdc71d176c3d2c3e569c1d26998d4def12d9d1c3 (patch)
tree5ec778ee67490e93e8bf86b7c467d620ca038d3f /CMakeLists.txt
parentdab31c329a4509eb581f0eb5e953bd260118221f (diff)
Port to CMake
Qt is slowly deprecating QMake. They have stopped building Qt itself with QMake and moved Qt6 to CMake instead. Although QMake is still around, it's clear the focus has shifted and it would be good for applications to switch over to an alternative build system as well So hereby, switch the build system to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..8f3648a
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,25 @@
+cmake_minimum_required(VERSION 3.6.0)
+
+project(asteroid-stopwatch
+ VERSION 0.0.1
+ DESCRIPTION "Default stopwatch app for AsteroidOS")
+
+find_package(ECM REQUIRED NO_MODULE)
+find_package(AsteroidApp REQUIRED)
+
+set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ASTEROID_MODULE_PATH})
+
+include(FeatureSummary)
+include(GNUInstallDirs)
+include(ECMQMLModules)
+include(AsteroidCMakeSettings)
+include(AsteroidTranslations)
+
+ecm_find_qmlmodule(Nemo.Configuration 1.0)
+
+add_subdirectory(src)
+
+build_translations(i18n)
+generate_desktop(${CMAKE_SOURCE_DIR} asteroid-stopwatch)
+
+feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)