summaryrefslogtreecommitdiff
path: root/daemon/CMakeLists.txt
diff options
context:
space:
mode:
authorArseniy-Movshev <dodoradio@outlook.com>2023-03-19 11:14:04 +0000
committerArseniy-Movshev <dodoradio@outlook.com>2023-05-26 00:32:20 +0100
commitec42177b24b47ba68b3ae49634c942c76a9f92d4 (patch)
treeb0b85601ef46f4e0bd8bb94f81eb89faaf8da5f1 /daemon/CMakeLists.txt
parentbfe0c3f7a03c53cff7a4050a42f14eaa210364f8 (diff)
Restructure to split to daemon and qml accessor
- add separate subdirs for daemon and qml - add some generic qml boilerplate - add a really lazy 'last value' loader implementation - license the project as gplv3 (add copyright notices and license text)
Diffstat (limited to 'daemon/CMakeLists.txt')
-rw-r--r--daemon/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/daemon/CMakeLists.txt b/daemon/CMakeLists.txt
new file mode 100644
index 0000000..7d38132
--- /dev/null
+++ b/daemon/CMakeLists.txt
@@ -0,0 +1,12 @@
+add_executable(healthd
+ sensorlogd.cpp
+ logger.cpp
+ logger.h
+ sensorPlugins/stepCounter.cpp
+ sensorPlugins/stepCounter.h
+ sensorPlugins/heartrateSensor.cpp
+ sensorPlugins/heartrateSensor.h
+)
+set_target_properties(healthd PROPERTIES AUTOMOC ON)
+#add_compile_definitions(Q_DECLARE_PRIVATE_SUPPORTS_UNIQUE_PTR=${Q_DECLARE_PRIVATE_SUPPORTS_UNIQUE_PTR})
+target_link_libraries(healthd PRIVATE Qt5::Core Qt5::DBus Qt5::Qml Qt5::Positioning Qt5::Sensors)