summaryrefslogtreecommitdiff
path: root/qmlplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorArseniy-Movshev <dodoradio@outlook.com>2023-05-28 13:08:04 +0100
committerArseniy-Movshev <dodoradio@outlook.com>2023-05-28 15:43:18 +0100
commit521c01825badf77c65a1389109e2f4967cde154d (patch)
tree7a47c6d9f85e442a566e8cd5490ec34f15f55742 /qmlplugin/CMakeLists.txt
parent9a838b7f9f56c2bd92a0aba72bcd37ec1f3d9f89 (diff)
Add a new LoggerSettings type
this independently accesses the settings file for the logger, and has a call to reinitialise it (which will cause settings to be reread)
Diffstat (limited to '')
-rw-r--r--qmlplugin/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/qmlplugin/CMakeLists.txt b/qmlplugin/CMakeLists.txt
index cb65f44..9455067 100644
--- a/qmlplugin/CMakeLists.txt
+++ b/qmlplugin/CMakeLists.txt
@@ -4,10 +4,12 @@ add_library(
sensorlogdqmlplugin.h
stepsDataLoader.cpp
stepsDataLoader.h
+ loggerSettings.cpp
+ loggerSettings.h
)
target_link_libraries(sensorlogdqmlplugin
- Qt5::Qml
+ Qt5::Qml Qt5::DBus
)
install(TARGETS sensorlogdqmlplugin