aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2023-05-09 10:34:53 +0200
committerMagneFire <dgriet@gmail.com>2023-05-14 19:38:37 +0200
commita8ab7af9c2672dcd03781688993a1692e6444715 (patch)
tree29acc5fa8c8cfacaa7eeceb3017cd26a9ffbbaf0 /CMakeLists.txt
parent23d104e70c9991f7b383a6c021b65c2f19a99d39 (diff)
Move main library file to CMAKE_INSTALL_LIBDIR and add a launch script
Previously the main program file was installed to /usr/bin, mistakingly giving the impression it could be executed as is. However it isn't a binary but a library that gets executed through invoker. To prevent confusion move it to /usr/lib and add a launch script to /usr/bin instead which launches it through invoker
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a7ab72..3b27f88 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,13 @@ ecm_find_qmlmodule(QtSensors 5.3)
add_subdirectory(src)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/asteroid-compass.in
+ ${CMAKE_BINARY_DIR}/asteroid-compass
+ @ONLY)
+
+install(PROGRAMS ${CMAKE_BINARY_DIR}/asteroid-compass
+ DESTINATION ${CMAKE_INSTALL_BINDIR})
+
build_translations(i18n)
generate_desktop(${CMAKE_SOURCE_DIR} asteroid-compass)