aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2023-05-09 10:34:53 +0200
committerMagneFire <dgriet@gmail.com>2023-05-14 19:38:37 +0200
commita8ab7af9c2672dcd03781688993a1692e6444715 (patch)
tree29acc5fa8c8cfacaa7eeceb3017cd26a9ffbbaf0 /src/CMakeLists.txt
parent23d104e70c9991f7b383a6c021b65c2f19a99d39 (diff)
Move main library file to CMAKE_INSTALL_LIBDIR and add a launch script
Previously the main program file was installed to /usr/bin, mistakingly giving the impression it could be executed as is. However it isn't a binary but a library that gets executed through invoker. To prevent confusion move it to /usr/lib and add a launch script to /usr/bin instead which launches it through invoker
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a9ef740..b5930c5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,8 +1,8 @@
add_library(asteroid-compass main.cpp resources.qrc)
-set_target_properties(asteroid-compass PROPERTIES PREFIX "" SUFFIX "")
+set_target_properties(asteroid-compass PROPERTIES PREFIX "")
target_link_libraries(asteroid-compass PUBLIC
AsteroidApp)
install(TARGETS asteroid-compass
- DESTINATION ${CMAKE_INSTALL_BINDIR})
+ DESTINATION ${CMAKE_INSTALL_LIBDIR})