summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordodoradio <dodoradio@github.com>2022-10-02 02:15:30 +0100
committerArseniy-Movshev <dodoradio@outlook.com>2022-11-05 20:03:44 +0000
commit287b52dd0e339574e11b05a5f6cbcf99e4d1dc93 (patch)
treec38655e45d3b09e11b4304e0573bfa163377956e /CMakeLists.txt
Initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f03e831
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,27 @@
+cmake_minimum_required(VERSION 3.10.0)
+project(healthd
+ VERSION 1.0.0
+ DESCRIPTION "A health tracker daemon for AsteroidOS"
+)
+
+find_package(ECM REQUIRED NO_MODULE)
+
+set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ASTEROID_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake)
+
+find_package(Qt5 COMPONENTS Core DBus Qml Positioning Sensors REQUIRED)
+
+
+add_executable(healthd
+ healthd.cpp
+ sensors.h
+ sensors.cpp
+)
+set_target_properties(healthd PROPERTIES AUTOMOC ON)
+#add_compile_definitions(Q_DECLARE_PRIVATE_SUPPORTS_UNIQUE_PTR=${Q_DECLARE_PRIVATE_SUPPORTS_UNIQUE_PTR})
+target_link_libraries(healthd PRIVATE Qt5::Core Qt5::DBus Qt5::Qml Qt5::Positioning Qt5::Sensors)
+install(TARGETS healthd)
+# configure_file(
+# "org.asteroid.steroid.trackrecorder.service.in"
+# "org.asteroid.steroid.trackrecorder.service"
+# )
+# install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.asteroid.steroid.trackrecorder.service DESTINATION /usr/lib/systemd/user)